Vendini Phone Issues
Incident Report for Vendini
Resolved
Thank you so much for your patience as we've worked through our phone issues. We believe we've gotten back to full functionality after the switch, but if you experience any further problems contacting support at 1 (800) 901-7173, option 2, please email support@vendini.com to let us know.
Posted Jan 16, 2020 - 06:14 PST
Update
Vendini is still in the process of switching our phone systems, but we are working to be back up and running as soon as we can. In the meantime, option 2 will allow you to leave a voicemail, option 4 will connect you with urgent support, and you can always reach the team by emailing support@vendini.com.
Posted Jan 14, 2020 - 13:48 PST
Investigating
Vendini is currently in the process of switching phone systems. Unfortunately, there was a miscommunication between our old provider and our new provider that caused us to be switched prematurely last week, and neither our normal support option (2) or our urgent support option (4) are currently operational. We are doing everything we can to get our phones back to full functionality as quickly as possible. In the meantime, please email support@vendini.com for assistance, and put URGENT in the subject line if you have an urgent issue.
Posted Jan 13, 2020 - 07:29 PST
This incident affected: Support Center.