Vendini's phone system is down
Incident Report for Vendini
Resolved
Our urgent support line is available for any issues that may come up over the weekend. Please call 1 (800) 901-7173, Option 4 for urgent support. Otherwise, please email support@vendini.com.
Posted Jan 10, 2020 - 18:19 PST
Investigating
Hi! Our phone service provider is experiencing issues that have caused an interruption in phone service on several lines including our main phone line. If you need assistance, please email support@vendini.com and we will respond as soon as possible.
Posted Jan 10, 2020 - 11:23 PST
This incident affected: Support Center.